Problemas al actualizar plugins o la versión de WordPress

Es posible que no seas capaz de actualizar plugins o ver las últimas actualizaciones para WordPress y tan solo puedas ver un error como «No tienes suficientes permisos para actualizar plugins para este sitio al acceder a la página «wp-admin/update-core.php».

Te recomiendo estos pasos:

1.- Comprobar a desactivar los plugins.

2.- Analizar los permisos de los directorios. Existe un plugin muy interesante llamado WP Security Scan que te permite analizar las posibles vulnerabilidades de tu instalación de wordpress así como los permisos dados en cada directorio.

3.- Permisos del administrador. Después de mirar las funciones, comprobar los permisos de cada directorio y no dar con el problema pensé que quizá los permisos del administrador podrían haberse modificado con la última actualización. El plugin para WordPress llamado «Capability Manager» te permitirá resetear todos los permisos por defecto de los usuarios y seguramente esta opción te ayudará a acceder correctamente  a todas tus funciones.

Instala el plugin y desde Herramientas –> Capability Manager utiliza la opción «Reset to WordPress defaults«

3 comentarios

Dejar una contestacion

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *